Query Functions in TIES

Types of searching available and views for creating queries

Creating Queries

Querying allows TIES users to search for cases and reports that are relevant to their research interests. To query reports, the user must be logged in as a Preliminary User, Researcher, or Honest Broker.

There are two basic views for querying reports: Dashboard and Diagram.

  • The Dashboard View –  similar to Google or other search tools that you might use.
  • The Diagram View –  more visual and allows for more complex queries and users can create queries by adding filters and constructing a diagram.

Types of Searching

When creating queries, users can use two main types of searches:

  • Text searching – only returns reports that contain EXACT matches to the search term.
  • Concept searching – returns documents that contain the exact search term as well as documents containing synonyms of the search term. Concept searching generally returns more accurate results.

In TIES, concept searching is the default search type.

One difference between concept and text searching is how NOT (negation) searches are treated. For text searches, reports not containing the search term anywhere in the report will be returned. In contrast, for concept searches, reports containing the search term in the negated form are returned (such as “No evidence of …”).

Basic Dashboard View

The Dashboard View is the default view for querying reports. To query reports:

  1. Type any specific search terms you want reports to contain into the text box, separating search terms with commas.
  2. Select the report type(s) you wish to search by clicking the appropriate checkboxes. By default, all report types available for the study you logged into will be searched.
  3. Select the sections you wish to search in by clicking the appropriate checkboxes. If you do not select any sections to search, the entire report will be searched. NOTE: You must select a document type first in order to select particular report sections.
  4. Restrict age, gender, and race as desired by clicking the demographics box.
  5. Restrict the event year and other criteria as desired.
  6. Select the number of reports desired from the drop-down list on the right-hand side of the screen. If you want a random selection of reports, check the “Randomize results” checkbox.
  7. Click the Start Search button.

NOTE: When a search term is matched to a concept, the search term will turn blue, and you can mouse over it to see what the concept is matched to.

Advanced Dashboard View

Additional search options are available by clicking the “Expand Search Options” link. These options include being able to use text searching (rather than concept searching), searching for any concepts listed (equivalent to “or” searching), and searching for concepts in the negated form (equivalent to “not” searching).

Diagram View

The Diagram View allows users to visually construct complex Boolean queries and temporal queries. Query diagrams consist of boxes connected by arrows. The boxes represent filters to the query and will cause reports to be filtered out. The arrows indicate the order in which all of the filters are checked on any report. Query results will be any reports that make it through all of the filters to the Filtered Reports placeholder. Below is a picture of the Diagram View:

Filters on the same path connected by arrows are AND filters – all of these conditions must be met for reports to be returned. Forks in the path indicate OR filters to the query.
Types of filters that can be added include:

  • Report type
  • Search term
  • NOT search term – include reports that do not contain the search term
  • Event year
  • Gender
  • Age
  • Race

Filters are added to the diagram either using the Filters panel on the left-hand side of the Diagram View, or by right clicking one of the placeholders or existing filters.

To add filters using the Filters panel, click the appropriate filter type button in the Filters panel. This will add a filter box below whatever was selected in the Diagram (with the exception of the Report Type filter, which is always placed at the top of the Diagram).

Inserting or deleting filters by right clicking items in the diagram simply involves selecting the appropriate option when right clicking. Options available when right clicking depend on what is clicked – for example, if you right click on the All Reports placeholder, the only option available is to add an AND filter below the placeholder since the All Reports placeholder must always appear at the top of the diagram and cannot be deleted. Then select the appropriate filter type from the dropdown and click OK. .

Temporal Queries

Temporal queries are queries done in Diagram form that connect one or more patients or events together. For more information about Temporal queries, please click here.

Specifying Filters

In the Diagram View, filters are specified in pop-up windows that appear after inserting the filter. In general, these pop-up windows function in the same manner as specifications made in the Dashboard View. However, specifying search terms requires additional steps.

For each search term added, you need to specify whether you want it to be a concept search or text search by clicking the appropriate button. If a concept search is performed, a pop-up window will appear where you type in the search term. Select the concept that most closely matches what you intend to search for. Note that you can select multiple concepts if desired. This step is performed automatically in the Dashboard View.

If you do not see the desired concept in the pop-up window, you can modify the search term by changing the term at the top of the pop-up window.

Start Over

In both the Dashboard and Diagram Views, you can click the StartOverButton button at any time to clear the query. After clicking the Start Over button, a pop-up window will appear asking if you are sure you want to start over with a blank query. Click Yes to clear the query, or click No or Cancel to go back to the current query.

Save a Query

Queries created using either the Dashboard or Diagram view can be saved for later use. To save a query:

  1. Click the SaveQueryButton button, or choose either the Save Query or Save Query As option from the File menu. A popup window will appear.
  2. Type the name you would like the query to be saved under in the Name field.
  3. If desired, type a more detailed description of the query in the Description field.
  4. Click the Save button to save your query.

Open a Query

To open a previously saved query:

  1. Click the OpenQueryButton button, or select the Open Query option from the File menu.
  2. Click the name of the query you want to open from the dialog box that appears.
  3. Click Open.

NOTE: You can also open queries saved by other users on the same study by selecting a different user from the drop-down list at the top of the Open Query window.

Viewing Query Results

After running a query, results will be displayed in a separate tab. The left-hand side of the screen displays a tree list of all reports returned from the query. Reports from the same institution are grouped together within the tree, as well as all reports for the same patient – if a patient has multiple reports, they will be kept together.

To view a particular report, click on the report in the tree list. The report will then be displayed on the right-hand side of the screen.

The report also has two other options: Data and Images. The Data tab allows for a more in-depth chart of all of the useful information known. The Images tab gives slide images of tissue samples.

Highlighting Reports
When a report is selected, search terms or annotations can be highlighted. Click the highlight-buttonbutton on the screen if you want items to be highlighted in the report. By selecting “All” in the dropdown menu, a legend will appear with the search terms and their corresponding colors.

Pop-Up Window
To open a report in a separate tab or window, click the pop-out-tool button. This will allow the entire document to be placed in a self-contained browser tab.

Changing Query
If after viewing query results you want to make changes to your query, click the link at the top of the Results page to go back to the query view you used to construct the query. You can also click on the Query tab (located to the left of the Results tab) at any time.

Report Options

Once a report is in view, a number of options are available. The report can be reviewed or quarantined. Reports can also be added to a case/order.

Request Report Review

If you come across a problematic report (for example, the report doesn’t fit the search you conducted or concepts are not colored correctly in the annotations), you can request that the report be reviewed.

  1. Click on the Request Review option button button  or right click the report and choose Request Review.
  2. Click Yes when the question “Do you want to request a review for this report?” pops up.
  3. Explain why you are requesting a review in the popup window that appears, and click OK.

NOTE: Once a report is flagged for review, it can only be un-flagged by a System Administrator.

Quarantine Report

If you come across any reports that are not completely de-identified (as occurs in less than 2% of the reports available), these reports must be quarantined so they are not available for searches.

  1. Click on the Quarantine Report option button buttonor right click the report and choose Quarantine.
  2. To confirm that you want to quarantine the report, click Yes in the popup window that appears.

NOTE: Reports can only be un-quarantined by a System Administrator.